Лисаков и макромир

Acestream в Ubuntu 16.04

Программа Acestream (форк VLC) для торрент-телевидения отлично устанавливалась из репозиториев в Ubuntu 14.04, но в шестнадцатой версии её в репозиториях пока ещё нет. Установка из исходников мне так и не удалась из-за конфликтов в зависимостях, но наконец нашёл рабочий способ установки, опробованный на Linux Mint 18. Должен сработать и в Debian, наверное. Перепишу его по-нашенски. Все файлы положил в один архив для удобства. Как Acestream появится в репах — дайте знать в комментариях, запись надо будет удалить.

Чтобы узнать, какая архитектура у компьютера — 32 или 64 бит — выполните команду uname -a. Если в выводе присутствует i686 или i386, то архитектура 32-битная, если в выводе есть x86_64, то архитектура 64-битная.

32-битная архитектура

  1. Скачивайте архив для своей архитектуры: Acestream 32 бит.

  2. Устанавливайте по порядку, пользуясь dpkg или gdebi:

    user ~ $
    user ~ $
    unzip acestream-32.zip
    cd acestream-32
    root acestream-32 #
    root acestream-32 #
    root acestream-32 #
    root acestream-32 #
    root acestream-32 #
    dpkg -i 00-libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb
    dpkg -i 01-acestream-engine_3.0.3-0.2_i386.deb
    dpkg -i 02-acestream-player-compat_3.0.2-1.1_i386.deb
    dpkg -i 03-acestream-player-data_3.0.2-1.1_i386.deb
    dpkg -i 04-acestream-player_3.0.2-1.1_i386.deb

64-битная архитектура

  1. Скачивайте архив для своей архитектуры: Acestream 64 бит.

  2. Устанавливайте по порядку, пользуясь dpkg или gdebi:

    user ~ $
    user ~ $
    unzip acestream-64.zip
    cd acestream-64
    root acestream-64 #
    root acestream-64 #
    root acestream-64 #
    root acestream-64 #
    root acestream-64 #
    dpkg -i 00-libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb
    dpkg -i 01-acestream-engine_3.0.5.1-0.2_amd64.deb
    dpkg -i 02-acestream-player-compat_3.0.2-1.1_amd64.deb
    dpkg -i 03-acestream-player-data_3.0.2-1.1_amd64.deb
    dpkg -i 04-acestream-player_3.0.2-1.1_amd64.deb

Дополнение

Если возникают ошибки вроде «trying to overwrite <filename> which is also in package <packagename>», можно добавить флаг --force-overwrite. Тогда указанный файл будет перезаписан и указанные программы, использующие этот файл, могут перестать работать, будьте внимательны!